antn zee
antn zee
[Mod note: Splited from as a update error and not working admin is a bit different.]

Hi, just discovered Arastta through my webhost's cpanel Softaculous App installer and am quite impressed. Have been searching for a good php/mysql opensource shopping cart script, and am surprised this great script is not visible when searching on google. For example: it's never mentioned on any sites recommending good opensource scripts.

Anyway, I downloaded the script but am having problem installing it, similar to what the original poster experienced. I noticed this original post was in 2016, but a final resolution to this problem was never posted.

I tried installing Arastta through Softaculous excellent cpanel installer, and everything looked fine. I could see the store front and click on the links with no problem, however, when I tried logging in to the admin panel, I get fa "This page isn't working. is currently unable to handle this request."

I uninstalled and reinstalled the script trying different Softaculous installation options, with no luck.

Then, I tried to install the script manually using Filezilla FTP upload to the root of my domain, and this time I can't even get the installer to work. Unlike with Softaculous, NOTHING can be installed. The script just hangs from the start, no installation screen is ever shown, and eventually, I get a "This page isn't working. mydomain is currently unable to handle this request."

Nothing I tried worked. I even tried to install previous versions of the script in the event this might be a recent bug with the most recent versions of the program ( version 1.62), but still no installation was possible.

I then tried doing a local install using a LAMP setup on my computer, and amazingly, the installation started up right away, no problem.

I then contacted my webhost (, and after 2 hours of diagnosing the problem, I was told that the problem was with a server the script was contacting at Here's a verbatim portion of the chat transcript with the hosting24 tech:

Hi, thank you for your patience waiting, I have found the problem with arastta script
The problem is that your script is trying to connect to domain which uses IP, this IP isn't blocked from our side but it looks like they are blocking our server's IP.
In order for it to start working you will need to contact arastta and ask them to unbock your server's IP which is

So, can someone at Arastta look into this problem. It looks like the problem is with the script trying to do an update routine from my webhost and is being blocked by a server on I don't even understand how Softaculous does the install, but apparently they can bypass the callback during their install, but I can't . I also can't bypass the callback when I try logging in to admin (another update callback must be made by the script at this time also.)

Thursday, October 19 2017, 09:56 AM
Share this post:
Responses (2)
  • Accepted Answer

    Thursday, October 19 2017, 03:36 PM - #Permalink
    Sadly the core teams bug fixing and forum support has failed, so I guess it's hard for anyone recommending it in those top free eCommerce lists. Still it's not invisible, it's linked to from several sites around the web.

    Sounds strange that you shouldn't be able to log into your admin because the update server is blocking your hosts server, it simply doesn't make sense to me.

    It also sounds strange to me that the update server should block any hosts, unless their IP is blacklisted globally because they are known spam servers.

    But hopefully the core team cares to look into it some day.
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, October 21 2017, 03:51 AM - #Permalink
    Your ip isn't on any of the common blacklists..
    The reply is currently minimized Show
Your Reply