Hi, I'm currently testing functionality of cart and run into these two issues.

After adding a product to the cart, I go to 'view cart' and all is fine. The two issues that affect the functionality are related to updating quantities.

Issue 1
When I press the delete product button - the shopping cart does not update to show the product was deleted from the cart. However, the upper right cart summary (next to the search box in the default theme) correctly updates the total. Once I press the reload button on my web browser, the cart content is updated correctly.

Is this a bug? or just some setting on my side? Any thoughts or ideas how to solve this ?

Issue 2
On the 'shopping cart' page - when I change the product quantity and press the 'update' button I get directed to an error page that shows the following info:

JSON

location "module"

HEADERS

Response Header
X-Firefox-Spdy: h2
cache-control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
content-type: application/json
date: Sat, 14 Oct 2017 16:05:10 GMT
expires: Thu, 19 Nov 1981 08:52:00 GMT
pragma: no-cache
server: Apache
x-arastta:


Request Header
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Encoding: gzip, deflate, br
Accept-Language: en-US,en;q=0.5
Connection: keep-alive
Content-Length: 446
Content-Type: multipart/form-data; boundary=---------------------------1312141056225
Cookie: PrestaShop-b3e06c535e0d602ffc2d031147d3eaa0=XJ2dXnSFG9W%2FDQp%2Fk1%2F2D0uZX5COrHETGKp00dZ2YEhRyCxX5xRc%2BWXphv0em7COCc7Gbt%2FhXc4ypllfogo%2FAUZE7AI0Kw%2BEprLSF7wE1g91T2rfZpy2yJDiHjPjLf2EfI0GeRgDiRY%2F%2FokblDFnTJhbSvhuYxdjXNa3BSqva5mwgg8a7K9XPSTvBNppaNhloK%2FE%2FkAworLsU5HCBknPZW%2FhvathC%2Bm%2BDHth5%2BLx0eZiyKmmxpoIw%2FdEl0s4cuaKApQb6n5CpDBsCOaZYC92xRRs6K3jZOFtyCxPHFlYBvBvISP0GNMs1C%2B8a3cwqxWQLAj4T%2FRTeFddsSk060Setg%3D%3D000242; PrestaShop-84f3888208825dd1c75a5d02a46cefc0=def5020038690f6a9e7b147c01c7bba74970bf73d8545e74426c656d747bd161faf746e75ce328fef01681923bef7c721ff5e948857ff72642d82b83aebb69140b631d76a201081d36fe2e08e33ca25e3c5faa38ae358d473116a0009801f8b529fd9a8153146d53426c31705082f836e1d72022da0f6c44f2f1cc25165b6180c5bd1f25e1278f397a0a993c43d3a2607cf326b2f301398d1fc1a802b6e4afa1b01a758bf6acea7e654541a84fa5485c857786677d948503b2188a0a1e; PrestaShop-af48b16d9336a9b6afdecdbd6c8e1f4b=def5020089497fb40738fcd8180ca87a02a195f9c22f9b26956dafaa354b44b6dbd81d1e8c2bf63bf08ed35a4516ff404a54f0ecd0d6f47221365b252ef9e72c0d8aba62108f6f5d38eb4e57b1a7142628e739eefc03f18165890ecbd5dc1201ffb73dbfab7d64423abcf36617b03b7a70580521d6bc648c49e524b88ba7e8432ee2163255af5912e6d728789fba5535549dfa044183034ba5106551b58652858364136b63d2ab128bac44675ef433e17adf6e45243a0319ee35e6175162faed9cf15c1ad66aebc44ba85cbab4ed3613b567ee57edef689a43e4f55c3359a97f14f0e0c18f00f7a16765594d0233a31a89d7511ef304f62dd4dd1b742fdf72911c700f6b83a82cff9aaec8c37a51d2313442ccb7a1fa7db6e5f996cd36e51fc3ebd83d7484f0d91f47977aef8c7645a19dfa1398fa54c196e3420dae759f828a532dd28269bee7bf2a6298bcc2118f64737342185c7b340bf6c6c471a7b1fc7a9c73; __stripe_mid=4c3251bf-292a-4449-a8ea-4d9bc2f20cad; currency=USD; language=en; __atuvc=16%7C41; PHPSESSID=ff2qcbrunppj7ibgmonvb80th7; __atuvs=59e22cd7268d84b900a
DNT: 1
Host: www.bluestarway.com
Referer: https://www.bluestarway.com/store/index.php/cart
Upgrade-Insecure-Requests: 1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0



Any thoughts on this one and what needs corrected ?

Thanks a lot
In General
Saturday, October 14 2017, 07:13 PM
Share this post:
Responses (11)
  • Accepted Answer

    Saturday, October 14 2017, 07:46 PM - #Permalink
    Correction!

    Please discard the error message for issue 2 (that was for the installation that went wrong). Here is the error message for the fresh installation of arastta cart:

    Response Header
    Cache-Control no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Connection Keep-Alive
    Content-Type application/json
    Date Sat, 14 Oct 2017 16:39:59 GMT
    Expires Thu, 19 Nov 1981 08:52:00 GMT
    Keep-Alive timeout=5
    Pragma no-cache
    Server Apache
    Transfer-Encoding chunked
    X-Arastta

    Request Header
    Accept text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Encoding gzip, deflate
    Accept-Language en-US,en;q=0.5
    Connection keep-alive
    Content-Length 246
    Content-Type multipart/form-data; boundary=---------------------------6729747410391
    Cookie __stripe_mid=4c3251bf-292a-4449-a8ea-4d9bc2f20cad; currency=USD; language=en; __atuvc=17%7C41; PHPSESSID=ff2qcbrunppj7ibgmonvb80th7; __stripe_mid=4c3251bf-292a-4449-a8ea-4d9bc2f20cad; __stripe_sid=2129a10b-6110-4b46-84c0-72a871d8f10b; __atuvs=59e23dcb4abb8596000
    DNT 1
    Host www.bluestarway.com
    Referer http://www.bluestarway.com/cart/index.php/cart
    Upgrade-Insecure-Requests 1
    User-Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
    The reply is currently minimized Show
  • Accepted Answer

    Sunday, October 15 2017, 01:18 PM - #Permalink
    Martin Riedel wrote:
    Is this a bug? or just some setting on my side?


    Since you haven't provided any information about your side, that is quite hard to tell.

    Tell us your about system information, configuration, which extensions you have installed, design you are using and such things.

    https://arastta.org/docs/user-manual/tools/system-information

    And also info about your browser ...

    Note! The demo works perfectly fine for me.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 18 2017, 07:21 PM - #Permalink
    Please note, I still need help with this, not sure how the conversation got marked as resolved.

    I checked the demo and it works fine for me too.

    I guess then the problem is on my side / server ?. Here is the information about my system (1st part):


    The only extensions I downloaded are:

    - stripe
    - Affiliate, Compare, Reward Points, Wishlist Feature Disable
    - Charity Donate

    The theme is based on the default theme - I followed the "override system" tutorial to create my custom theme which really has nothing modified in it yet. This brings me to another thing which I will address in a different entry so as to not confuse things.
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 18 2017, 07:26 PM - #Permalink
    Switch to default theme, clear cache, test.
    Disable/Remove installed extensions one by one, clear cache, test.

    T.ex. that old outdated charity crap modifies the checkout.

    Note! When you are asked to add info, you should add it!
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 18 2017, 07:31 PM - #Permalink
    I cleared the cache using the systems - settings - cache. Looking at the tools - cache manager page I see the following:

    Group Files Size
    System 14 128 KB
    Image 145 2665 KB
    Modification 67 2088 KB

    Should I delete these files too?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 18 2017, 07:52 PM - #Permalink
    Hi again,

    I just did a fresh installation on a new folder with a new database to check things out. I have the same problem on the cart. So it's not an extension or modification I have made. Seems like something in my server is not working right. I saw someone had a similar problem and they solved it by changing their server's php version.

    Here is my system information:

    Value
    Platform Arastta 1.6.2 Stable [ Tianjin ] 29-August-2017 15:30 GMT +3
    PHP Version 5.6.31
    PHP Built On Linux venera.vivawebhost.com 3.10.0-693.2.2.el7.x86_64 #1 SMP Tue Sep 12 22:26:13 UTC 2017 x86_64
    Database Version 5.5.5-10.0.32-MariaDB
    Database Collation latin1_swedish_ci
    Web Server Apache
    Server Interface (SAPI) cgi-fcgi
    User Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0

    admin Writable
    catalog Writable
    download Writable
    image Writable
    system/cache Writable
    system/log Writable
    system/modification Writable
    upload Writable
    vqmod Writable

    Safe Mode Disabled
    Register Globals Disabled
    Magic Quotes Disabled
    File Uploads Enabled
    Session Auto Start Disabled
    Session Save Path /var/cpanel/php/sessions/ea-php56
    Display Errors Disabled
    Output Buffering Enabled
    GD Enabled
    cURL Enabled
    mCrypt Enabled
    ZIP Enabled
    Zlib Enabled
    Mbstring Enabled
    Iconv Enabled
    Open basedir
    Disabled Functions
    The reply is currently minimized Show
  • Accepted Answer

    Friday, November 03 2017, 03:50 AM - #Permalink
    I have resolved this way
    catalog/controller/checkout cart.php open with editor;
    find text
    (!empty($this->request->post['quantity']) && $json['location'] != 'module') {
    change
    (!empty($this->request->post['quantity']) ) {
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, November 04 2017, 05:56 PM - #Permalink
    Hm ... this part you removed, was added here long time ago, 31 Mar 2016:
    https://github.com/arastta/arastta/commit/feb58a21ec9a53af84cadea74f90d14b730b3907#diff-6334cac8bb0e12f4ee27dba6bbb667f6

    Sure you didn't break anything else by removing it?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, November 17 2017, 04:00 PM - #Permalink
    Removing that will break the popup shown after adding a product to cart.

    My local and demo work fine for me. Are you able to reproduce it Rune?

    Can you guys send us your domain/store link so we could see this in action?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, November 17 2017, 04:47 PM - #Permalink
    Martins installation is here, using default theme it seems: https://www.bluestarway.com/cart/

    I just tested it on a close to fresh demo in Second, and got the same result as Martin described: https://demo.arastta.no/

    1. Going to the shopping cart and deleting the product doesn't update the cart itself, only the module.

    2. Pushing update gives a blank page displaying only: {"location":"module"}

    Platform Arastta 1.6.2 Stable [ Tianjin ] 29-August-2017 15:30 GMT +3
    PHP 5.6.32
    Database 5.6.38-log
    Tjener Apache
    Servergrensesnitt (SAPI) litespeed
    Brukeragent Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

    Edit! Same when using PHP 7.0.25
    The reply is currently minimized Show
  • Accepted Answer

    Friday, November 17 2017, 04:53 PM - #Permalink
    Just noticed something ...

    The demo at http://demo.arastta.org is it latest version?

    It's using a different address to the cart than my demo and Martins site, it's using 'checkout/cart', on our it's just 'cart' ...

    Edit/Update! When I go to 'System -> URL Manager' and deletes the 'cart' URL from there, it starts working.

    Edit/Update 2! This https://github.com/arastta/arastta/commit/01231df93b2ee3192099249fddc706e3fafb0e6c#diff-b816f6e1bb129e7d6a0979953409832d
    Btw! It's not added on updated sites it seems, so only way to recreate is on a fresh demo install.
    The reply is currently minimized Show
Your Reply