Hi Folks

Using Customizer I was "playing" with the webshop image - changing it for something more suitable - but then the option to change/upload an image disappeared from the menu and the webshop name appeared as text instead.

https://www.nativasbuxton.co.uk/question.jpg

how do I repair this please? How do I get back to being able to upload an image for the Header?

I'm using the Default theme ...

Thank you,

Bryan.
In Themes
Sunday, May 12 2019, 05:55 PM
Share this post:
Responses (1)
  • Accepted Answer

    Hackasacka
    Hackasacka
    Offline
    Tuesday, May 14 2019, 12:01 AM - #Permalink
    Hi Bryan,

    Arastta has HTML and PHP in the header of the "Default" template.

    /catalog/view/theme/default/template/common/header.tpl (line 116-124)

    <div class="col-sm-5">
    <div id="logo">
    <?php if ($logo) { ?>
    <a href="/<?php echo $home; ?>"><img src="/<?php echo $logo; ?>" title="<?php echo $name; ?>" alt="<?php echo $name; ?>" class="img-responsive" /></a>
    <?php } else { ?>
    <h1><a href="/<?php echo $home; ?>"><?php echo $name; ?></a></h1>
    <?php } ?>
    </div>
    </div>


    What appears to have happened is that you have not selected an image for the logo so the logic of the template replaces the logo image link to the home page with an h1 text link to the home page.

    Although, it is not clear why the option to change this logo image has disappeared in the "Customiser" it can be accessed or modified with more than one method.

    1. System -> Settings -> Image (tab) - Change the Store Logo (it should be possible to use the "Customiser" again now too.

    2. Using PhpMyAdmin to access the MYSQL database and the arxx_setting table and look for the record "customiser_default logo" or "config config_logo". It is most probably right near the end at around setting id 1049 - 1050.

    Edit the database with the new image reference.

    3. Hard code the "header.tpl" replacing the code above with something similar to:-

    <div class="col-sm-5">
    <div id="logo">
    <a href="/<?php echo $home; ?>"><img src="http://mywebstoredomain.com/image/catalog/mynewlogo.png" title="<?php echo $name; ?>" alt="<?php echo $name; ?>" class="img-responsive" /></a>
    </div>
    </div>


    It looks like you uncovered a bug in the way the "Admin" backend allows you to customise the theme, but you can easily resolve it with any of the above options.


    Regards,

    Hackasacka
    The reply is currently minimized Show
Your Reply